
    
    
      
        The complete checklist to PDF accessibility

        
          
            
            
            
            
          
        

        
          
            
              In this article

              	What does PDF accessibility mean?
	What makes a PDF accessible?
	Top ways to make your PDFs accessible
	How to create accessible PDFs
	Adobe Acrobat features and tools


            

          

        

        Accessibility involves two key issues — how users with disabilities access electronic information and how web content designers and developers enable web pages to function with assistive devices used by individuals with disabilities.

        For business owners and publishers, it’s essential to deliver outstanding digital experiences to everyone. That means supporting the creation of rich, engaging web pages and content that are readable and accessible to all users. And that’s why PDF accessibility matters. By adjusting and applying different settings, you can ensure no one has difficulty viewing and enjoying your content.

        PDF accessibility is important for a range of reasons, from broad issues of equality and legality to basic aims of inclusivity and wanting your content to be available to anyone. Business owners and digital publishers need to know why and how to enable it.

        What does PDF accessibility mean?

        The World Health Organization (WHO) estimates there’s 43 million people worldwide who are blind. An inaccessible document would be like looking at a blank page. WHO also estimates that 295 million people have low vision, meaning an inaccessible document could appear blurry. The organization estimates 780 million around the globe have dyslexia — inaccessible content is like trying to read a page written in code. Untagged PDFs can be difficult or even impossible to read with a screen reader, and of the 2.5 trillion PDFs worldwide, more than 90 percent are untagged.

        
          
            
              PDF accessibility means a document is able to be accessed and read by everyone, including people with disabilities.

            

          

        

        PDF file format accessibility features combined with Adobe Acrobat and Adobe Reader allow universal access to documents. A digital document or web application is considered accessible if it meets certain technical criteria and can be used by people with disabilities. This includes access for people who are mobility impaired, blind, low vision, deaf, hard of hearing, or who have cognitive impairments.

        Accessibility features in Adobe Acrobat, Adobe Reader and in the Portable Document Format (PDF) make it easier for people with disabilities to use PDF documents and forms, with and without the aid of assistive technology software and devices such as screen readers, screen magnifiers, text-to-speech software, speech recognition software, alternative input devices, Braille embossers, and refreshable Braille displays.

        The Web Content Accessibility Guidelines (WCAG) 2.0 (ISO/IEC 40500:2012) and the PDF/UA (ISO 14289-1) standards cover a wide range of recommendations for making content more accessible to people with disabilities. One benefit of following these guidelines is that content becomes more readable for all users.

        What makes a PDF accessible?

        Accessible PDFs include but are not limited to the following characteristics:

        	Searchable text
	Fonts that allow characters to be extracted to text
	Other interactive features — hyperlinks and navigational aids
	Document language and title indication
	Security that will not interfere with assistive technology
	Document structure tags and proper reading order
	Alternative text descriptions for non-text elements


        Top features to look for to create an accessible PDF

        When you’re looking to create an accessible PDF, there are some important features you should have in a document tool, including:

        	Ability to create tagged PDFs from authoring applications
	Ability to convert untagged PDFs to tagged PDFs from within Acrobat
	Security settings that allow screen readers to access text while preventing users from copying, printing, editing, and extracting text
	Ability to add text to scanned pages to improve accessibility
	Tools for editing reading order and document structure
	Tools for creating accessible PDF forms
	Ability to set document properties like title and expose them through the title bar of the application


        Adobe Acrobat and Adobe Acrobat Reader accessibility features

        Accessibility features in Adobe Acrobat and Adobe Acrobat Reader fall into two broad categories: features that make the reading of PDF documents more accessible, and features that help create accessible PDF documents. To create accessible PDF documents, you must use Acrobat Pro.

        Features to support the reading of PDFs by people with disabilities

        All versions of Adobe Acrobat, Adobe Acrobat Reader, Acrobat Standard, and Acrobat Pro provide support for the accessible reading of PDF files by persons with disabilities. Though Acrobat Standard provides some functionality for making existing PDFs accessible, Acrobat Pro must be used to perform most tasks — such as editing reading order or editing document structure tags — that are necessary to make PDF documents and forms accessible.

        Top ways to make your PDFs accessible

        To create accessible PDFs you need to have the right tools. Acrobat makes it easy to create accessible PDFs and check the accessibility of existing PDFs. Here we’ll show you how to make a PDF more accessible using Acrobat Pro.

        Make PDFs accessible (Acrobat Pro)

        Using Adobe Acrobat, you can make a PDF accessible with these simple steps.

        	Choose Tools > Action Wizard.


        	The Action Wizard toolset is displayed in the secondary toolbar.


        	From the Actions List, click Make Accessible.


        	The right-hand pane changes to display each task included in the Make Accessible action, as well as the instructions to execute the action.


        	Select the files that you want to apply the Make Accessible action to.


        	By default, the action runs on the document that’s currently open. Select Add Files to select additional files or a folder to run the action on.


        	Click Start.
	Follow the prompts to complete the Make Accessible action.


        How to check the accessibility of a PDF

        A good way to check the accessibility of a document is to use tools that your readers will use. Even if you do not have access to those tools, Adobe Acrobat provides an automated way to check the accessibility of a PDF file. The Full Check/Accessibility Check feature in Acrobat checks a PDF for many of the characteristics of accessible PDFs. You can choose which accessibility problems to look for and how you want the results reported.

        	Choose Tools > Accessibility.


        	The Accessibility toolset is displayed in the secondary toolbar.


        	In the secondary toolbar, click Full Check/Accessibility Check.


        	The Accessibility Checker Options dialog box is displayed.


        	In the Report Options section, select options for how you want to view the results.


        	You can save the results as an HTML file on your system, or attach the results file to the document itself.


        	Select a page range if you prefer to check individual pages of a document.
	Select one or more of the Checking Options.
	Click Start Checking.


        	The results are displayed in the Accessibility Checker panel on the left, which also has helpful links and hints for repairing issues.
	If you created a report in step 2, the results are available in the selected folder.


        Because the Full Check/Accessibility Check feature cannot distinguish between essential and nonessential content types, some issues it reports don’t affect readability. It’s a good idea to review all issues to determine which ones require correction.

        The report displays one of the following statuses for each rule check:

        	Passed. The item is accessible.
	Skipped By User. Rule was not checked because it wasn’t selected in the Accessibility Checker Options dialog box.
	Needs Manual Check. The Full Check/Accessibility Check feature couldn’t check the item automatically, so you must verify the item manually.
	Failed. The item didn’t pass the accessibility check.


        How to fix accessibility issues with Acrobat Pro

        To fix a failed check after running Full Check/Accessibility Check, right-click (Windows) or Ctrl-click (Mac OS) the item in the Accessibility Checker panel. Choose one of the following options from the context menu:

        	Fix — either fixes the item automatically or displays a dialog box prompting you to fix the item manually.
	Skip Rule — deselects this option in the Accessibility Checker Options dialog box for future checks of this document and changes the item status to Skipped.
	Explain — opens the online Help where you can get more details about the accessibility issue.
	Check Again — runs the checker again on all items. Choose this option after modifying one or more items.
	Show Report — displays a report with links to tips on how to repair failed checks.
	Options — opens the Accessibility Checker Options dialog box, so you can select which checks are performed.


        How to create accessible PDFs

        Now that we’ve learned how to check and fix accessibility issues, let’s dive into the top things to consider when creating any PDF to make sure it’s accessible.

        	Consider accessibility before you convert a document to PDF. Whenever possible, think about accessibility when you create the source files in an authoring application, such as a word-processing or page-layout application. Typical tasks in the authoring application include adding alternate text to graphics, optimizing tables, and applying paragraph styles or other document-structure features that can be converted to tags.


        	Add fillable form fields and descriptions, and set the tab order. If your PDF includes form fields, use Tools > Accessibility > Run Form Field Recognition to detect form fields and make them interactive (fillable). Use the Forms tools to create fillable form fields, such as buttons, check boxes, pop-up menus, and text boxes. When you create a field, type a description in the Tooltip box in the Properties dialog box for that field. Screen readers read this text aloud to the user.


        	Add other accessibility features to the PDF. In Acrobat Pro, this stage includes setting the document language, making sure that security settings don’t interfere with screen readers, creating accessible links, and adding bookmarks. In Acrobat Standard, this stage includes setting the document language, making sure that security settings don’t interfere with screen readers, and adding bookmarks.


        	Tag the PDF. Improve the accessibility of PDFs by adding tags in Acrobat. If a PDF doesn’t contain tags, Acrobat attempts to tag it automatically when users read or reflow it, and the results may be disappointing. With a tagged PDF, the logical structure tree sends the contents to a screen reader or other assistive software or hardware in an appropriate order. For best results, tag a document when converting it to PDF from an authoring application.


        	Evaluate the PDF and repair tagging problems. Once you’ve tagged a PDF, evaluate the document for reading order problems, tagging errors, and accessibility errors, and then repair them as needed. Irrespective of the method that you use to tag the PDF, use Acrobat to touch up the tagging and reading order for complex page layouts or unusual page elements.


        These stages are presented in an order that suits most scenarios. However, you can perform tasks in a different order or iterate between some of the stages. In all cases, identify the purpose of the document and then determine the appropriate workflow.

        Create a tagged PDF from a web page

        A PDF that you create from a web page is only as accessible as the HTML source that it is based on. For example, if the web page relies on tables for its layout design, the HTML code for the table may not flow in the same logical reading order as a tagged PDF would require, even though the HTML code is sufficiently structured to display all the elements correctly in a browser.

        Depending on the complexity of the web page, you can do extensive repairs in Acrobat Pro by using the Reading Order tool or editing the tag tree in Acrobat. To produce the most accessible PDFs from web pages that you create, first establish a logical reading order in their HTML code. For best results, employ the Web Content Accessibility Guidelines that are published by the World Wide Web Consortium (W3C).

        	Do one of the following:


        	In Acrobat, choose File > Create > PDF From Web Page, enter the web page address, and then click Settings.
	In Microsoft Internet Explorer, in the Adobe PDF toolbar, click the down arrow on the Convert button and choose Preferences.


        	In the General tab, select Create PDF Tags, and then select OK.
	Specify any other options as appropriate, and then select Create.


        About tools for creating accessible PDF forms

        Adobe offers various tools for the creation of accessible PDF forms.

        Acrobat Pro, Acrobat Standard: Use one of these applications to open untagged or tagged PDF forms (except PDF forms that are created from Adobe Designer) to add fillable form fields, such as text boxes, check boxes, and buttons. Then use the application’s other tools to make the form accessible. Add descriptions to form fields, tag untagged forms, set the set tab order, manipulate tags, and perform the other PDF accessibility tasks.

        Authoring applications: Most authoring applications that you can use to design forms don’t retain their fillable form fields when you convert the files to PDF. Use the forms tools in Acrobat Pro to add fillable form fields. Moreover, if you tag the form during conversion to PDF, the authoring application can generate inappropriate tags for the text labels of the form fields.

        Adobe Acrobat features and tools

        With Adobe Acrobat, you have a full set of digital document features and tools to help create, edit, publish, and support accessible PDFs, such as:

        	Merge PDF
	Compress PDF
	JPG to PDF
	PDF to Word
	PDF to Excel
	Rearrange PDF
	Requestsignature
	Redact a PDF
	Crop PDF
	Print PDF
	Create PDF
	Edit PDF
	Add pages to a PDF
	Extract PDF pages
	Convert to and from a PDF
	PDF to JPG
	Word to PDF
	Sign PDF
	PDF to PPT
	Excel to PDF
	PPT to PDF
	Split PDF
	Sign fillable PDF forms
	Remove PDFpassword
	Delete PDF pages
	Rotate PDF
	Password protect PDF
	Scan to PDF
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